CVEvulnerability
CVE-2025-57822
8.2 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2025-08-29
- Last modified
- 2026-10-18
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N
- CVSS 3.1 ([email protected])
- 8.2 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
- Weaknesses
- CWE-918
Description
Next.js is a React framework for building full-stack web applications. Prior to versions 14.2.32 and 15.4.7, when next() was used without explicitly passing the request object, it could lead to SSRF in self-hosted applications that incorrectly forwarded user-supplied headers. This vulnerability has been fixed in Next.js versions 14.2.32 and 15.4.7. All users implementing custom middleware logic in self-hosted environments are strongly encouraged to upgrade and verify correct usage of the next() function.
Affected configurations
• vercel next.js (< 14.2.32)
• vercel next.js (>= 15.0.0 < 15.4.7)
Related
Weakness · CWE (1)
- CWE-918 Server-Side Request Forgery weakness
References
- https://github.com/vercel/next.js/commit/9c9aaed5bb9338ef31b0517ccf0ab4414f2093d8 Patch
- https://github.com/vercel/next.js/security/advisories/GHSA-4342-x723-ch2f Vendor Advisory
- https://vercel.com/changelog/cve-2025-57822 Mitigation, Vendor Advisory