CVEvulnerability
CVE-2025-58098
8.3 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2025-12-05
- Last modified
- 2026-09-25
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 8.3 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L
- Weaknesses
- CWE-201
Description
Apache HTTP Server 2.4.65 and earlier with Server Side Includes (SSI) enabled and mod_cgid (but not mod_cgi) passes the shell-escaped query string to #exec cmd="..." directives.
This issue affects Apache HTTP Server before 2.4.66.
Users are recommended to upgrade to version 2.4.66, which fixes the issue.
Affected configurations
• apache http server (< 2.4.66)
Related
Weakness · CWE (1)
- CWE-201 Insertion of Sensitive Information Into Sent Data weakness
References
- https://httpd.apache.org/security/vulnerabilities_24.html Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2025/12/04/5 Mailing List, Third Party Advisory