CVEvulnerability
CVE-2025-58457
4.3 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2025-09-24
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 4.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-280
Description
Improper permission check in ZooKeeper AdminServer lets authorized clients to run snapshot and restore command with insufficient permissions.
This issue affects Apache ZooKeeper: from 3.9.0 before 3.9.4.
Users are recommended to upgrade to version 3.9.4, which fixes the issue.
The issue can be mitigated by disabling both commands (via admin.snapshot.enabled and admin.restore.enabled), disabling the whole AdminServer interface (via admin.enableServer), or ensuring that the root ACL does not provide open permissions. (Note that ZooKeeper ACLs are not recursive, so this does not impact operations on child nodes besides notifications from recursive watches.)
Affected configurations
• apache zookeeper (>= 3.9.0 < 3.9.4)
Related
Weakness · CWE (1)
- CWE-280 Improper Handling of Insufficient Permissions or Privileges weakness
References
- https://lists.apache.org/thread/r5yol0kkhx2fzw22pxk1ozwm3oc6yxrx Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2025/09/24/10 www.openwall.com