CVEvulnerability
CVE-2025-59270
2.3 LOW
Official page ↗
- Status
- Analyzed
- Published
- 2025-09-16
- Last modified
- 2026-06-17
- Assigner
- 9119a7d8-5eab-497f-8521-727c672e3725
- CVSS 4.0 (9119a7d8-5eab-497f-8521-727c672e3725)
- 2.3 LOW — CVSS:4.0/AV:A/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 (9119a7d8-5eab-497f-8521-727c672e3725)
- 3.1 LOW — CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-757
Description
psPAS PowerShell module does not explicitly enforce TLS 1.2 within the 'Get-PASSAMLResponse' function during the SAML authentication process. An unauthenticated attacker in a 'Man-in-the-Middle' position could manipulate the TLS handshake and downgrade TLS to a deprecated protocol. Fixed in 7.0.209.
Affected configurations
• pspete pspas (>= 6.4.85 < 7.0.209)
Related
Weakness · CWE (1)
- CWE-757 Selection of Less-Secure Algorithm During Negotiation weakness
References
- https://github.com/pspete/psPAS/commit/2a8b1b4bc001bec9969ea512ed83386ed3e0b8f8#diff-e40bf02e86c8a8babbb20529ecaef6a069d8b5ea21701dca429dce78181109a7L37-R75 Patch
- https://github.com/pspete/psPAS/releases/tag/v7.0.209 Release Notes
- https://raw.githubusercontent.com/cisagov/CSAF/develop/csaf_files/IT/white/2025/va-25-258-01.json Third Party Advisory
- https://www.cve.org/CVERecord?id=CVE-2025-59270 Third Party Advisory