CVEvulnerability
CVE-2025-59302
4.7 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2025-11-27
- Last modified
- 2026-10-18
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 4.7 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L
- Weaknesses
- CWE-94
Description
In Apache CloudStack improper control of generation of code ('Code Injection') vulnerability is found in the following APIs which are accessible only to admins.
* quotaTariffCreate
* quotaTariffUpdate
* createSecondaryStorageSelector
* updateSecondaryStorageSelector
* updateHost
* updateStorage
This issue affects Apache CloudStack: from 4.18.0 before 4.20.2, from 4.21.0 before 4.22.0. Users are recommended to upgrade to versions 4.20.2 or 4.22.0, which contain the fix.
The fix introduces a new global configuration flag, js.interpretation.enabled, allowing administrators to control the interpretation of JavaScript expressions in these APIs, thereby mitigating the code injection risk.
Affected configurations
• apache cloudstack (>= 4.18.0.0 < 4.20.2.0)
• apache cloudstack 4.21.0.0
Related
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness
References
- https://lists.apache.org/thread/kwwsg2j85f1b75o0ht5zbr34d7h66788 Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2025/11/27/2 Mailing List, Third Party Advisory