CVEvulnerability
CVE-2025-59454
4.3 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2025-11-27
- Last modified
- 2026-10-18
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 4.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-200
Description
In Apache CloudStack, a gap in access control checks affected the APIs - createNetworkACL
- listNetworkACLs
- listResourceDetails
- listVirtualMachinesUsageHistory
- listVolumesUsageHistory
While these APIs were accessible only to authorized users, insufficient permission validation meant that users could occasionally access information beyond their intended scope.
Users are recommended to upgrade to Apache CloudStack 4.20.2.0 or 4.22.0.0, which fixes the issue.
Affected configurations
• apache cloudstack (>= 4.0.0 < 4.20.2.0)
• apache cloudstack 4.21.0.0
Related
Weakness · CWE (1)
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness
References
- https://lists.apache.org/thread/0hlklvlwhzsfw39nocmyxb6svjbs9xbc Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2025/11/27/3 Mailing List, Third Party Advisory