CVEvulnerability
CVE-2025-5953
8.8 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2025-07-04
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-862
Description
The WP Human Resource Management plugin for WordPress is vulnerable to Privilege Escalation due to missing authorization in the ajax_insert_employee() and update_empoyee() functions in versions 2.0.0 through 2.2.17. The AJAX handler reads the client-supplied $_POST['role'] and, after basic cleaning via hrm_clean(), passes it directly to wp_insert_user() and later to $user->set_role() without verifying that the current user is allowed to assign that role. This makes it possible for authenticated attackers, with Employee-level access and above, to elevate their privileges to administrator.
Affected configurations
• mishubd wp human resource management (>= 2.0.0 <= 2.2.17)
Related
Weakness · CWE (1)
- CWE-862 Missing Authorization weakness
References
- https://plugins.trac.wordpress.org/browser/hrm/tags/2.2.17/class/employee.php#L543 Product
- https://plugins.trac.wordpress.org/browser/hrm/tags/2.2.17/class/employee.php#L591 Product
- https://plugins.trac.wordpress.org/browser/hrm/tags/2.2.17/class/employee.php#L89 Product
- https://wordpress.org/plugins/hrm/#developers Release Notes
- https://www.wordfence.com/threat-intel/vulnerabilities/id/3ba33a18-429f-4a3e-b018-bdfbbe6e8482?source=cve Third Party Advisory