CVEvulnerability
CVE-2025-59940
6.5 MEDIUM
Official page ↗
- Status
- Deferred
- Published
- 2025-09-29
- Last modified
- 2026-10-09
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
- Weaknesses
- CWE-20
Description
mkdocs-include-markdown-plugin is an Mkdocs Markdown includer plugin. In versions 7.1.7 and below, there is a vulnerability where unvalidated input can collide with substitution placeholders. This issue is fixed in version 7.1.8.
Related
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://github.com/mondeja/mkdocs-include-markdown-plugin/commit/7466d67aa0de8ffbc427204ad2475fed07678915 github.com
- https://github.com/mondeja/mkdocs-include-markdown-plugin/issues/274 github.com
- https://github.com/mondeja/mkdocs-include-markdown-plugin/pull/277 github.com
- https://github.com/mondeja/mkdocs-include-markdown-plugin/security/advisories/GHSA-v39m-5m9j-m9w9 github.com