CVEvulnerability
CVE-2025-59944
9.8 CRITICAL
Official page ↗
- Status
- Analyzed
- Published
- 2025-10-03
- Last modified
- 2026-10-19
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.0 HIGH — CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-178
Description
Cursor is a code editor built for programming with AI. Versions 1.6.23 and below contain case-sensitive checks in the way Cursor IDE protects its sensitive files (e.g., */.cursor/mcp.json), which allows attackers to modify the content of these files through prompt injection and achieve remote code execution. A prompt injection can lead to full RCE through modifying sensitive files on case-insensitive fileystems. This issue is fixed in version 1.7.
Affected configurations
• anysphere cursor (<= 1.6.23)
Related
Weakness · CWE (1)
- CWE-178 Improper Handling of Case Sensitivity weakness