CVEvulnerability

CVE-2025-6140

1.9 LOW Published 2025-06-16 Modified 2026-06-17 Official page ↗
Status
Analyzed
Published
2025-06-16
Last modified
2026-06-17
Assigner
[email protected]
CVSS 4.0 ([email protected])
1.9 LOW — CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1 ([email protected])
3.3 LOW — CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
CVSS 2.0 ([email protected])
1.7 LOW — AV:L/AC:L/Au:S/C:N/I:N/A:P
Weaknesses
CWE-400, CWE-404

Description

A vulnerability, which was classified as problematic, was found in spdlog up to 1.15.1. This affects the function scoped_padder in the library include/spdlog/pattern_formatter-inl.h. The manipulation leads to resource consumption. It is possible to launch the attack on the local host. The exploit has been disclosed to the public and may be used. Upgrading to version 1.15.2 is able to address this issue. The identifier of the patch is 10320184df1eb4638e253a34b1eb44ce78954094. It is recommended to upgrade the affected component.

Affected configurations

• gabime spdlog (< 1.15.2)

Related

Weakness · CWE (2)

  • CWE-400 Uncontrolled Resource Consumption weakness
  • CWE-404 Improper Resource Shutdown or Release weakness

References