CVEvulnerability
CVE-2025-61622
9.8 CRITICAL
Official page ↗
- Status
- Analyzed
- Published
- 2025-10-01
- Last modified
- 2026-10-09
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-502
Description
Deserialization of untrusted data in python in pyfory versions 0.12.0 through 0.12.2, or the legacy pyfury versions from 0.1.0 through 0.10.3: allows arbitrary code execution. An application is vulnerable if it reads pyfory serialized data from untrusted sources. An attacker can craft a data stream that selects pickle-fallback serializer during deserialization, leading to the execution of `pickle.loads`, which is vulnerable to remote code execution.
Users are recommended to upgrade to pyfory version 0.12.3 or later, which has removed pickle fallback serializer and thus fixes this issue.
Affected configurations
• apache fory (>= 0.1.0 <= 0.10.3)
• apache fory (>= 0.12.0 <= 0.12.2)
Related
Weakness · CWE (1)
- CWE-502 Deserialization of Untrusted Data weakness
References
- https://lists.apache.org/thread/vfn9hp9qt06db5yo1gmj3l114o3o2csd Issue Tracking, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2025/09/29/3 Mailing List, Third Party Advisory