CVEvulnerability
CVE-2025-61915
6.7 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2025-11-29
- Last modified
- 2026-10-07
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.0 MEDIUM — CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:N/I:N/A:H
- CVSS 3.1 ([email protected])
- 6.7 MEDIUM — CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-124, CWE-129
Description
OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. Prior to version 2.4.15, a user in the lpadmin group can use the cups web ui to change the config and insert a malicious line. Then the cupsd process which runs as root will parse the new config and cause an out-of-bound write. This issue has been patched in version 2.4.15.
Affected configurations
• openprinting cups (< 2.4.15)
Related
References
- https://github.com/OpenPrinting/cups/commit/db8d560262c22a21ee1e55dfd62fa98d9359bcb0 Patch
- https://github.com/OpenPrinting/cups/releases/tag/v2.4.15 Release Notes
- https://github.com/OpenPrinting/cups/security/advisories/GHSA-hxm8-vfpq-jrfc Exploit, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2025/11/27/5 Mailing List, Third Party Advisory
- https://github.com/OpenPrinting/cups/security/advisories/GHSA-hxm8-vfpq-jrfc Exploit, Vendor Advisory