CVEvulnerability

CVE-2025-62164

8.8 HIGH Published 2025-11-21 Modified 2026-10-19 Official page ↗
Status
Analyzed
Published
2025-11-21
Last modified
2026-10-19
Assigner
[email protected]
CVSS 3.1 ([email protected])
8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-123, CWE-20, CWE-502, CWE-787

Description

vLLM is an inference and serving engine for large language models (LLMs). From versions 0.10.2 to before 0.11.1, a memory corruption vulnerability could lead to a crash (denial-of-service) and potentially remote code execution (RCE), exists in the Completions API endpoint. When processing user-supplied prompt embeddings, the endpoint loads serialized tensors using torch.load() without sufficient validation. Due to a change introduced in PyTorch 2.8.0, sparse tensor integrity checks are disabled by default. As a result, maliciously crafted tensors can bypass internal bounds checks and trigger an out-of-bounds memory write during the call to to_dense(). This memory corruption can crash vLLM and potentially lead to code execution on the server hosting vLLM. This issue has been patched in version 0.11.1.

Affected configurations

• vllm vllm (>= 0.10.2 < 0.11.1) • vllm vllm 0.11.1

Related

Weakness · CWE (4)

  • CWE-123 Write-what-where Condition weakness
  • CWE-20 Improper Input Validation weakness
  • CWE-502 Deserialization of Untrusted Data weakness
  • CWE-787 Out-of-bounds Write weakness

References