CVEvulnerability

CVE-2025-62372

8.3 HIGH Published 2025-11-21 Modified 2026-10-19 Official page ↗
Status
Analyzed
Published
2025-11-21
Last modified
2026-10-19
Assigner
[email protected]
CVSS 4.0 ([email protected])
8.3 HIGH — CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1 ([email protected])
6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-129

Description

vLLM is an inference and serving engine for large language models (LLMs). From version 0.5.5 to before 0.11.1, users can crash the vLLM engine serving multimodal models by passing multimodal embedding inputs with correct ndim but incorrect shape (e.g. hidden dimension is wrong), regardless of whether the model is intended to support such inputs (as defined in the Supported Models page). This issue has been patched in version 0.11.1.

Affected configurations

• vllm vllm (>= 0.5.5 < 0.11.1) • vllm vllm 0.11.1

Related

Weakness · CWE (1)

  • CWE-129 Improper Validation of Array Index weakness

References