CVEvulnerability
CVE-2025-62504
7.5 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2025-10-16
- Last modified
- 2026-10-09
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-416
Description
Envoy is an open source edge and service proxy. Envoy versions earlier than 1.36.2, 1.35.6, 1.34.10, and 1.33.12 contain a use-after-free vulnerability in the Lua filter. When a Lua script executing in the response phase rewrites a response body so that its size exceeds the configured per_connection_buffer_limit_bytes (default 1MB), Envoy generates a local reply whose headers override the original response headers, leaving dangling references and causing a crash. This results in denial of service. Updating to versions 1.36.2, 1.35.6, 1.34.10, or 1.33.12 fixes the issue. Increasing per_connection_buffer_limit_bytes (and for HTTP/2 the initial_stream_window_size) or increasing per_request_buffer_limit_bytes / request_body_buffer_limit can reduce the likelihood of triggering the condition but does not correct the underlying memory safety flaw.
Affected configurations
• envoyproxy envoy (< 1.33.12)
• envoyproxy envoy (>= 1.34.0 < 1.34.10)
• envoyproxy envoy (>= 1.35.0 < 1.35.6)
• envoyproxy envoy (>= 1.36.0 < 1.36.2)
Related
Weakness · CWE (1)
- CWE-416 Use After Free weakness