CVEvulnerability
CVE-2025-64408
6.3 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2025-11-19
- Last modified
- 2026-10-18
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 6.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- Weaknesses
- CWE-502
Description
Apache Causeway faces Java deserialization vulnerabilities that allow remote code execution (RCE) through user-controllable URL parameters. These vulnerabilities affect all applications using Causeway's ViewModel functionality and can be exploited by authenticated attackers to execute arbitrary code with application privileges.
This issue affects all current versions.
Users are recommended to upgrade to version 3.5.0, which fixes the issue.
Affected configurations
• apache causeway (>= 2.0.0 < 3.5.0)
• apache causeway 4.0.0
Related
Weakness · CWE (1)
- CWE-502 Deserialization of Untrusted Data weakness
References
- https://lists.apache.org/thread/rjlg4spqhmgy1xgq9wq5h2tfnq4pm70b Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2025/11/19/1 Mailing List, Third Party Advisory