CVEvulnerability
CVE-2025-64428
8.9 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2025-11-20
- Last modified
- 2026-10-19
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 8.9 HIGH — CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-74
Description
Dataease is an open source data visualization analysis tool. Versions prior to 2.10.17 are vulnerable to JNDI injection. A blacklist was added in the patch for version 2.10.14. However, JNDI injection remains possible via the iiop, corbaname, and iiopname schemes. The vulnerability has been fixed in version 2.10.17.
Affected configurations
• dataease dataease (< 2.10.17)
Related
Weakness · CWE (1)
- CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness
References
- https://github.com/dataease/dataease/commit/b7e585c1cc3fc2b73cb289b8680b4b3914be3d53 Patch
- https://github.com/dataease/dataease/releases/tag/v2.10.17 Release Notes
- https://github.com/dataease/dataease/security/advisories/GHSA-88ph-3236-2m2h Exploit, Vendor Advisory
- https://github.com/dataease/dataease/security/advisories/GHSA-88ph-3236-2m2h Exploit, Vendor Advisory