CVEvulnerability
CVE-2025-6466
2.1 LOW
Official page ↗
- Status
- Analyzed
- Published
- 2025-06-22
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 2.1 LOW — CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 6.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 6.5 MEDIUM — AV:N/AC:L/Au:S/C:P/I:P/A:P
- Weaknesses
- CWE-284, CWE-434
Description
A vulnerability was found in ageerle ruoyi-ai 2.0.0 and classified as critical. Affected by this issue is the function speechToTextTranscriptionsV2/upload of the file ruoyi-modules/ruoyi-system/src/main/java/org/ruoyi/system/service/impl/SseServiceImpl.java. The manipulation of the argument File leads to unrestricted upload. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.1 is able to address this issue. The patch is identified as 4e93ac86d4891c59ecfcd27c051de9b3c5379315. It is recommended to upgrade the affected component.
Affected configurations
• ageerle ruoyi-ai (< 2.0.1)
Related
References
- https://github.com/ageerle/ruoyi-ai/commit/4e93ac86d4891c59ecfcd27c051de9b3c5379315 Patch
- https://github.com/ageerle/ruoyi-ai/issues/9 Exploit, Issue Tracking
- https://github.com/ageerle/ruoyi-ai/issues/9#event-16775988438 Exploit, Issue Tracking
- https://github.com/ageerle/ruoyi-ai/releases/tag/v2.0.1 Release Notes
- https://vuldb.com/?ctiid.313574 Permissions Required, VDB Entry
- https://vuldb.com/?id.313574 Third Party Advisory, VDB Entry
- https://vuldb.com/?submit.598365 Third Party Advisory, VDB Entry
- https://github.com/ageerle/ruoyi-ai/issues/9#event-16775988438 Exploit, Issue Tracking