CVEvulnerability

CVE-2025-64751

5.8 MEDIUM Published 2025-11-21 Modified 2026-10-19 Official page ↗
Status
Analyzed
Published
2025-11-21
Last modified
2026-10-19
Assigner
[email protected]
CVSS 4.0 ([email protected])
5.8 MEDIUM — CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1 ([email protected])
8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-285

Description

OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA v1.4.0 to v1.11.0 ( openfga-0.1.34 <= Helm chart <= openfga-0.2.48, v.1.4.0 <= docker <= v.1.11.0) are vulnerable to improper policy enforcement when certain Check and ListObject calls are executed. This issue has been patched in version 1.11.1.

Affected configurations

• openfga helm charts (>= 0.1.34 < 0.2.49) • openfga openfga (>= 1.4.0 < 1.11.1)

Related

Weakness · CWE (1)

  • CWE-285 Improper Authorization weakness

References