CVEvulnerability
CVE-2025-65105
5.3 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2025-12-02
- Last modified
- 2026-10-18
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 4.5 MEDIUM — CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L
- CVSS 3.1 ([email protected])
- 5.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-61, CWE-706
Description
Apptainer is an open source container platform. In Apptainer versions less than 1.4.5, a container can disable two of the forms of the little used --security option, in particular the forms --security=apparmor:<profile> and --security=selinux:<label> which otherwise put restrictions on operations that containers can do. The --security option has always been mentioned in Apptainer documentation as being a feature for the root user, although these forms do also work for unprivileged users on systems where the corresponding feature is enabled. Apparmor is enabled by default on Debian-based distributions and SElinux is enabled by default on RHEL-based distributions, but on SUSE it depends on the distribution version. This vulnerability is fixed in 1.4.5.
Affected configurations
• lfprojects apptainer (< 1.4.5)
Related
References
- https://github.com/apptainer/apptainer/commit/4313b42717e18a4add7dd7503528bc15af905981 Patch
- https://github.com/apptainer/apptainer/commit/82f17900a0c31bc769bf9b4612d271c7068d8bf2 Patch
- https://github.com/apptainer/apptainer/pull/3226 Issue Tracking
- https://github.com/apptainer/apptainer/security/advisories/GHSA-j3rw-fx6g-q46j Patch, Vendor Advisory
- https://github.com/opencontainers/runc/security/advisories/GHSA-cgrx-mc8f-2prm Not Applicable
- https://github.com/sylabs/singularity/security/advisories/GHSA-wwrx-w7c9-rf87 Not Applicable