CVEvulnerability

CVE-2025-65199

7.3 HIGH Published 2025-12-10 Modified 2026-09-28 Official page ↗
Status
Analyzed
Published
2025-12-10
Last modified
2026-09-28
Assigner
9119a7d8-5eab-497f-8521-727c672e3725
CVSS 4.0 (9119a7d8-5eab-497f-8521-727c672e3725)
7.3 HIGH — CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1 (9119a7d8-5eab-497f-8521-727c672e3725)
7.8 HIGH — CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-78

Description

A command injection vulnerability exists in Windscribe for Linux Desktop App that allows a local user who is a member of the windscribe group to execute arbitrary commands as root via the 'adapterName' parameter of the 'changeMTU' function. Fixed in Windscribe v2.18.3-alpha and v2.18.8.

Affected configurations

• windscribe windscribe (>= 2.10.1 <= 2.17.10) • windscribe windscribe 2.18.1 • windscribe windscribe 2.18.3 • windscribe windscribe 2.18.5

Related

Weakness · CWE (1)

  • CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness

References