CVEvulnerability
CVE-2025-66170
6.5 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2026-05-08
- Last modified
- 2026-10-07
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-863
Description
The CloudStack Backup plugin has an improper authorization logic in versions 4.21.0.0 and 4.22.0.0. Anyone with authenticated user-account access in CloudStack 4.21.0.0+ environments, where this plugin is enabled and has access to specific APIs can list backups from any account in the environment. This vulnerability does not allow them to see the contents of the backup.
Users are recommended to upgrade to version 4.22.0.1, which fixes the issue.
Affected configurations
• apache cloudstack (>= 4.21.0.0 < 4.22.0.1)
Related
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness
References
- https://lists.apache.org/thread/n8mt5b7wkpysstb8w7rr9f02kc5cq2xm Mailing List, Third Party Advisory
- http://www.openwall.com/lists/oss-security/2026/05/09/1 Mailing List, Third Party Advisory