CVEvulnerability
CVE-2025-66201
8.6 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2025-11-29
- Last modified
- 2026-10-07
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 8.6 HIGH — CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 8.1 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-20, CWE-918
Description
LibreChat is a ChatGPT clone with additional features. Prior to version 0.8.1-rc2, LibreChat is vulnerable to Server-side Request Forgery (SSRF), by passing specially crafted OpenAPI specs to its "Actions" feature and making the LLM use those actions. It could be used by an authenticated user with access to this feature to access URLs only accessible to the LibreChat server (such as cloud metadata services, through which impersonation of the server might be possible). This issue has been patched in version 0.8.1-rc2.
Affected configurations
• librechat librechat (< 0.8.1)
• librechat librechat 0.8.1
Related
References
- https://github.com/danny-avila/LibreChat/security/advisories/GHSA-7m2q-fjwr-5x8v Exploit, Vendor Advisory
- https://github.com/danny-avila/LibreChat/security/advisories/GHSA-7m2q-fjwr-5x8v Exploit, Vendor Advisory