CVEvulnerability
CVE-2025-66301
8.6 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2025-12-01
- Last modified
- 2026-09-26
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 8.6 HIGH — CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 9.6 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N
- Weaknesses
- CWE-285
Description
Grav is a file-based Web platform. Prior to 1.8.0-beta.27, due to improper authorization checks when modifying critical fields on a POST request to /admin/pages/{page_name}, an editor with only permissions to change basic content on the form is now able to change the functioning of the form through modifying the content of the data[_json][header][form] which is the YAML frontmatter which includes the process section which dictates what happens after a user submits the form which include some important actions that could lead to further vulnerabilities. This vulnerability is fixed in 1.8.0-beta.27.
Affected configurations
• getgrav grav (< 1.8.0)
• getgrav grav 1.8.0
Related
Weakness · CWE (1)
- CWE-285 Improper Authorization weakness
References
- https://github.com/getgrav/grav/security/advisories/GHSA-v8x2-fjv7-8hjh Exploit, Third Party Advisory
- https://github.com/getgrav/grav/security/advisories/GHSA-v8x2-fjv7-8hjh Exploit, Third Party Advisory