CVEvulnerability

CVE-2025-66451

5.3 MEDIUM Published 2025-12-11 Modified 2026-10-07 Official page ↗
Status
Analyzed
Published
2025-12-11
Last modified
2026-10-07
Assigner
[email protected]
CVSS 4.0 ([email protected])
5.3 MEDIUM — CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1 ([email protected])
6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Weaknesses
CWE-20, CWE-915

Description

LibreChat is a ChatGPT clone with additional features. In versions 0.8.0 and below, when creating prompts, JSON requests are sent to define and modify the prompts via PATCH endpoint for prompt groups (/api/prompts/groups/:groupId). However, the request bodies are not sufficiently validated for proper input, enabling users to modify prompts in a way that was not intended as part of the front end system. The patchPromptGroup function passes req.body directly to updatePromptGroup() without filtering sensitive fields. This issue is fixed in version 0.8.1.

Affected configurations

• librechat librechat (< 0.8.1)

Related

Weakness · CWE (2)

  • CWE-20 Improper Input Validation weakness
  • CWE-915 Improperly Controlled Modification of Dynamically-Determined Object Attributes weakness

References