CVEvulnerability
CVE-2025-66562
8.9 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2025-12-05
- Last modified
- 2026-09-25
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 8.9 HIGH — CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 9.6 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-79, CWE-94
Description
TUUI is a desktop MCP client designed as a tool unitary utility integration. Prior to 1.3.4, a critical Remote Code Execution (RCE) vulnerability exists in Tuui due to an unsafe Cross-Site Scripting (XSS) flaw in the Markdown rendering component. Tuui allows the execution of arbitrary JavaScript within ECharts code blocks. Combined with an exposed IPC interface that allows spawning processes, an attacker can execute arbitrary system commands on the victim's machine simply by having them view a malicious Markdown message. This vulnerability is fixed in 1.3.4.
Affected configurations
• aiql tuui (< 1.3.4)
Related
References
- https://github.com/AI-QL/tuui/commit/f673fa5b4d76e8236c7d9506d0727875cfa79cc1 Patch
- https://github.com/AI-QL/tuui/releases/tag/v1.3.4 Product, Release Notes
- https://github.com/AI-QL/tuui/security/advisories/GHSA-qjhq-rgmr-6c3g Patch, Vendor Advisory