CVEvulnerability
CVE-2025-66627
7.8 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2025-12-09
- Last modified
- 2026-10-14
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.4 HIGH — CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 7.8 HIGH — CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-416
Description
Wasmi is a WebAssembly interpreter focused on constrained and embedded systems. In versions 0.41.0, 0.41.1, 0.42.0 through 0.47.1, 0.50.0 through 0.51.2 and 1.0.0, Wasmi's linear memory implementation leads to a Use After Free vulnerability, triggered by a WebAssembly module under certain memory growth conditions. This issue potentially leads to memory corruption, information disclosure, or code execution. This issue is fixed in versions 0.41.2, 0.47.1, 0.51.3 and 1.0.1. To workaround this issue, consider limiting the maximum linear memory sizes where feasible.
Affected configurations
• wasmi-labs wasmi (>= 0.41.0 < 0.41.2)
• wasmi-labs wasmi (>= 0.47.0 < 0.47.1)
• wasmi-labs wasmi (>= 0.51.0 < 0.51.3)
• wasmi-labs wasmi 1.0.0
Related
Weakness · CWE (1)
- CWE-416 Use After Free weakness
References
- https://github.com/wasmi-labs/wasmi/security/advisories/GHSA-g4v2-cjqp-rfmq Patch, Vendor Advisory