CVEvulnerability
CVE-2025-66675
8.2 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2025-12-10
- Last modified
- 2026-10-14
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 8.2 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H
- Weaknesses
- CWE-459
Description
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion.
This issue affects Apache Struts: from 2.0.0 through 6.7.4, from 7.0.0 through 7.0.3.
Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.
It's related to https://cve.org/CVERecord?id=CVE-2025-64775 - this CVE addresses missing affected version 6.7.4
Affected configurations
• apache struts (>= 2.0.0 <= 2.3.37)
• apache struts (>= 2.5.0 <= 2.5.33)
• apache struts (>= 6.0.0 < 6.8.0)
• apache struts (>= 7.0.0 < 7.1.1)
Related
Weakness · CWE (1)
- CWE-459 Incomplete Cleanup weakness
References
- https://cve.org/CVERecord?id=CVE-2025-64775 Third Party Advisory
- https://cwiki.apache.org/confluence/display/WW/S2-068 Vendor Advisory