CVEvulnerability
CVE-2025-67504
9.8 CRITICAL
Official page ↗
- Status
- Analyzed
- Published
- 2025-12-09
- Last modified
- 2026-10-07
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-331, CWE-338
Description
WBCE CMS is a content management system. Versions 1.6.4 and below use function GenerateRandomPassword() to create passwords using PHP's rand(). rand() is not cryptographically secure, which allows password sequences to be predicted or brute-forced. This can lead to user account compromise or privilege escalation if these passwords are used for new accounts or password resets. The vulnerability is fixed in version 1.6.5.
Affected configurations
• wbce wbce cms (< 1.6.5)
Related
References
- https://cwe.mitre.org/data/definitions/338.html Technical Description
- https://github.com/WBCE/WBCE_CMS/commit/5d59fe021a5c6e469b1bf192b72ca652e54278f6 Patch
- https://github.com/WBCE/WBCE_CMS/releases/tag/1.6.5 Release Notes
- https://github.com/WBCE/WBCE_CMS/security/advisories/GHSA-76gj-pmvx-jcc6 Exploit, Vendor Advisory
- https://github.com/WBCE/WBCE_CMS/security/advisories/GHSA-76gj-pmvx-jcc6 Exploit, Vendor Advisory