CVEvulnerability
CVE-2025-67716
5.7 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2025-12-11
- Last modified
- 2026-10-14
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.7 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-184
Description
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions 4.9.0 through 4.12.1 contain an input-validation flaw in the returnTo parameter, which could allow attackers to inject unintended OAuth query parameters into the Auth0 authorization request. Successful exploitation may result in tokens being issued with unintended parameters. This issue is fixed in version 4.13.0.
Affected configurations
• auth0 nextjs-auth0 (>= 4.9.0 < 4.12.1)
Related
Weakness · CWE (1)
- CWE-184 Incomplete List of Disallowed Inputs weakness