CVEvulnerability
CVE-2025-67746
1.3 LOW
Official page ↗
- Status
- Analyzed
- Published
- 2025-12-30
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 1.3 LOW — CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 4.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- Weaknesses
- CWE-74
Description
Composer is a dependency manager for PHP. In versions on the 2.x branch prior to 2.2.26 and 2.9.3, attackers controlling remote sources that Composer downloads from might in some way inject ANSI control characters in the terminal output of various Composer commands, causing mangled output and potentially leading to confusion or DoS of the terminal application. There is no proven exploit and this has thus a low severity but we still publish a CVE as it has potential for abuse, and we want to be on the safe side informing users that they should upgrade. Versions 2.2.26 and 2.9.3 contain a patch for the issue.
Affected configurations
• getcomposer composer (>= 2.0.0 < 2.2.26)
• getcomposer composer (>= 2.3.0 < 2.9.3)
Related
Weakness · CWE (1)
- CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness
References
- https://github.com/composer/composer/commit/1d40a95c9d39a6b7f80d404ab30336c586da9917 Patch
- https://github.com/composer/composer/commit/5db1876a76fdef76d3c4f8a27995c434c7a43e71 Patch
- https://github.com/composer/composer/releases/tag/2.2.26 Product, Release Notes
- https://github.com/composer/composer/releases/tag/2.9.3 Product, Release Notes
- https://github.com/composer/composer/security/advisories/GHSA-59pp-r3rg-353g Vendor Advisory