CVEvulnerability
CVE-2025-6775
2.1 LOW
Official page ↗
- Status
- Analyzed
- Published
- 2025-06-27
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 2.1 LOW — CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 6.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 6.5 MEDIUM — AV:N/AC:L/Au:S/C:P/I:P/A:P
- Weaknesses
- CWE-74, CWE-77
Description
A vulnerability classified as critical has been found in xiaoyunjie openvpn-cms-flask up to 1.2.7. This affects the function create_user of the file /app/api/v1/openvpn.py of the component User Creation Endpoint. The manipulation of the argument Username leads to command injection. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.2.8 is able to address this issue. The patch is named e23559b98c8ea2957f09978c29f4e512ba789eb6. It is recommended to upgrade the affected component.
Affected configurations
• xiaoyunjie openvpn-cms-flask (< 1.2.8)
Related
References
- https://github.com/xiaoyunjie/openvpn-cms-flask/commit/e23559b98c8ea2957f09978c29f4e512ba789eb6 Patch
- https://github.com/xiaoyunjie/openvpn-cms-flask/issues/24 Exploit, Issue Tracking, Vendor Advisory
- https://github.com/xiaoyunjie/openvpn-cms-flask/issues/24#issuecomment-2948563464 Exploit, Issue Tracking, Vendor Advisory
- https://github.com/xiaoyunjie/openvpn-cms-flask/releases/tag/v1.2.8 Release Notes
- https://vuldb.com/?ctiid.314091 Permissions Required, VDB Entry
- https://vuldb.com/?id.314091 Third Party Advisory, VDB Entry
- https://vuldb.com/?submit.602373 Third Party Advisory, VDB Entry