CVEvulnerability

CVE-2025-68493

8.1 HIGH Published 2026-01-11 Modified 2026-07-15 Official page ↗
Status
Modified
Published
2026-01-11
Last modified
2026-07-15
Assigner
[email protected]
CVSS 3.1 ([email protected])
8.1 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
8.1 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
CVSS 3.1 (0b0ca135-0b70-47e7-9f44-1890c2a1c46c)
7.1 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:L
Weaknesses
CWE-112, CWE-611

Description

Missing XML Validation vulnerability in Apache Struts, Apache Struts. This issue affects Apache Struts: from 2.0.0 before 2.2.1; Apache Struts: from 2.2.1 through 6.1.0. Users are recommended to upgrade to version 6.1.1, which fixes the issue.

Affected configurations

• apache struts (>= 2.0.0 <= 2.3.37) • apache struts (>= 2.5.0 <= 2.5.33) • apache struts (>= 6.0.0 < 6.1.1)

Related

Weakness · CWE (2)

  • CWE-112 Missing XML Validation weakness
  • CWE-611 Improper Restriction of XML External Entity Reference weakness

References