CVEvulnerability
CVE-2025-68615
9.8 CRITICAL
Official page ↗
- Status
- Analyzed
- Published
- 2025-12-23
- Last modified
- 2026-10-19
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-119
Description
net-snmp is a SNMP application library, tools and daemon. Prior to versions 5.9.5 and 5.10.pre2, a specially crafted packet to an net-snmp snmptrapd daemon can cause a buffer overflow and the daemon to crash. This issue has been patched in versions 5.9.5 and 5.10.pre2.
Affected configurations
• net-snmp net-snmp (< 5.9.5)
• net-snmp net-snmp 5.10
• debian debian linux 11.0
Related
Weakness · CWE (1)
- CWE-119 Improper Restriction of Operations within the Bounds of a Memory Buffer weakness
References
- https://github.com/net-snmp/net-snmp/security/advisories/GHSA-4389-rwqf-q9gq Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/01/09/2 Mailing List, Third Party Advisory
- https://lists.debian.org/debian-lts-announce/2026/01/msg00000.html Mailing List, Vendor Advisory
- https://www.vicarius.io/vsociety/posts/cve-2025-68615-detection-script-buffer-overflow-vulnerability-affecting-net-snmp Exploit, Mitigation, Third Party Advisory
- https://www.vicarius.io/vsociety/posts/cve-2025-68615-mitigation-script-buffer-overflow-vulnerability-affecting-net-snmp Mitigation, Third Party Advisory