CVEvulnerability
CVE-2025-68637
9.1 CRITICAL
Official page ↗
- Status
- Analyzed
- Published
- 2026-01-07
- Last modified
- 2026-10-07
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-297
Description
The Uniffle HTTP client is configured to trust all SSL certificates and
disables hostname verification by default. This insecure configuration
exposes all REST API communication between the Uniffle CLI/client and the
Uniffle Coordinator service to potential Man-in-the-Middle (MITM) attacks.
This issue affects all versions from before 0.10.0.
Users are recommended to upgrade to version 0.10.0, which fixes the issue.
Affected configurations
• apache uniffle (< 0.10.0)
Related
Weakness · CWE (1)
- CWE-297 Improper Validation of Certificate with Host Mismatch weakness
References
- https://lists.apache.org/thread/trvdd11hmpbjno3t8rc9okr4t036ox2v Issue Tracking, Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2025/12/27/2 Mailing List, Third Party Advisory