CVEvulnerability
CVE-2025-69262
7.8 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-01-07
- Last modified
- 2026-10-14
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 7.8 HIGH — CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-78, CWE-94
Description
pnpm is a package manager. Versions 6.25.0 through 10.26.2 have a Command Injection vulnerability when using environment variable substitution in .npmrc configuration files with tokenHelper settings. An attacker who can control environment variables during pnpm operations could achieve Remote Code Execution (RCE) in build environments. This issue is fixed in version 10.27.0.
Affected configurations
• pnpm pnpm (>= 6.25.0 < 10.27.0)
Related
References
- https://github.com/pnpm/pnpm/releases/tag/v10.27.0 Product, Release Notes
- https://github.com/pnpm/pnpm/security/advisories/GHSA-2phv-j68v-wwqx Exploit, Vendor Advisory
- https://github.com/pnpm/pnpm/security/advisories/GHSA-2phv-j68v-wwqx Exploit, Vendor Advisory