CVEvulnerability

CVE-2025-6965

7.2 HIGH Published 2025-07-15 Modified 2026-10-15 Official page ↗
Status
Modified
Published
2025-07-15
Last modified
2026-10-15
Assigner
[email protected]
CVSS 4.0 ([email protected])
7.2 HIGH — CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:L/VI:H/VA:L/SC:L/SI:H/SA:L/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:N/AU:N/R:U/V:D/RE:L/U:Green
CVSS 3.1 ([email protected])
7.7 HIGH — CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:H/A:L
Weaknesses
CWE-197

Description

There exists a vulnerability in SQLite versions before 3.50.2 where the number of aggregate terms could exceed the number of columns available. This could lead to a memory corruption issue. We recommend upgrading to version 3.50.2 or above.

Affected configurations

• sqlite sqlite (< 3.50.2) • apple ipados (< 26.0.0) • apple iphone os (< 26.0.0) • apple macos (< 26.0.0) • apple tvos (< 26.0.0) • apple visionos (< 26.0.0) • apple watchos (< 26.0.0) • siemens ruggedcom crossbow (< 5.8) • siemens sidis prime (< 4.0.800)

Related

Weakness · CWE (1)

  • CWE-197 Numeric Truncation Error weakness

References