CVEvulnerability

CVE-2025-6981

5.3 MEDIUM Published 2025-07-15 Modified 2026-06-17 Official page ↗
Status
Analyzed
Published
2025-07-15
Last modified
2026-06-17
Assigner
[email protected]
CVSS 4.0 ([email protected])
5.3 MEDIUM — CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1 ([email protected])
4.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-863

Description

An incorrect authorization vulnerability allowed unauthorized read access to the contents of internal repositories for contractor accounts when the Contractors API feature was enabled. The Contractors API is a rarely-enabled feature in private preview. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.18 and was fixed in versions 3.14.15, 3.15.10, 3.16.6 and 3.17.3

Affected configurations

• github enterprise server (< 3.14.5) • github enterprise server (>= 3.15.0 < 3.15.10) • github enterprise server (>= 3.16.0 < 3.16.6) • github enterprise server (>= 3.17.0 < 3.17.3)

Related

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References