CVEvulnerability
CVE-2025-8715
8.8 HIGH
Official page ↗
- Status
- Deferred
- Published
- 2025-08-14
- Last modified
- 2026-06-17
- Assigner
- f86ef6dc-4d3a-42ad-8f28-e6d5547a5007
- CVSS 3.1 (f86ef6dc-4d3a-42ad-8f28-e6d5547a5007)
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-93
Description
Improper neutralization of newlines in pg_dump in PostgreSQL allows a user of the origin server to inject arbitrary code for restore-time execution as the client operating system account running psql to restore the dump, via psql meta-commands inside a purpose-crafted object name. The same attacks can achieve SQL injection as a superuser of the restore target server. pg_dumpall, pg_restore, and pg_upgrade are also affected. Versions before PostgreSQL 17.6, 16.10, 15.14, 14.19, and 13.22 are affected. Versions before 11.20 are unaffected. CVE-2012-0868 had fixed this class of problem, but version 11.20 reintroduced it.
Related
Weakness · CWE (1)
- CWE-93 Improper Neutralization of CRLF Sequences weakness
References
- https://www.postgresql.org/support/security/CVE-2025-8715/ www.postgresql.org