CVEvulnerability
CVE-2025-9353
6.4 MEDIUM
Official page ↗
- Status
- Deferred
- Published
- 2025-09-24
- Last modified
- 2026-09-26
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.4 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
Description
The Themify Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several parameters in all versions up to, and including, 7.6.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 7.6.9.
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://plugins.trac.wordpress.org/browser/themify-builder/trunk/js/editor/build/modules.min.js plugins.trac.wordpress.org
- https://plugins.trac.wordpress.org/browser/themify-builder/trunk/templates/template-fancy-heading.php#L73 plugins.trac.wordpress.org
- https://plugins.trac.wordpress.org/browser/themify-builder/trunk/templates/template-fancy-heading.php#L96 plugins.trac.wordpress.org
- https://plugins.trac.wordpress.org/browser/themify-builder/trunk/templates/template-icon.php#L95 plugins.trac.wordpress.org
- https://plugins.trac.wordpress.org/changeset/3355757/ plugins.trac.wordpress.org
- https://plugins.trac.wordpress.org/changeset/3366817/ plugins.trac.wordpress.org
- https://www.wordfence.com/threat-intel/vulnerabilities/id/508e97a0-9757-426c-bf0f-cdce6b489ce7?source=cve www.wordfence.com