CVEvulnerability

CVE-2026-102495

7.5 HIGH Published 2026-09-29 Modified 2026-10-06 Official page ↗
Status
Analyzed
Published
2026-09-29
Last modified
2026-10-06
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-674

Description

Apache XmlSchema doesn't limit how deeply schema imports and includes can be nested, so a malicious schema can make parsing recurse until the stack overflows. This causes a denial of service. Users are recommended to upgrade to version 2.3.3, which fixes this issue.

Affected configurations

• apache xmlschema (< 2.3.3)

Related

Weakness · CWE (1)

  • CWE-674 Uncontrolled Recursion weakness

References