CVEvulnerability
CVE-2026-102827
9.8 CRITICAL
Official page ↗
- Status
- Analyzed
- Published
- 2026-09-29
- Last modified
- 2026-10-08
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.1 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-77, CWE-88
Description
simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. Prior to 4.0.0, the default blockUnsafeOperationsPlugin compares parsed option names with literal dangerous option spellings while Git accepts unambiguous long-option abbreviations. Attacker-influenced push arguments such as abbreviated --receive-pack or --exec forms can therefore bypass detectVulnerableFlags, reach git push against a local or file remote or an attacker-influenced receive-pack target, and cause Git to invoke an attacker-selected command in consumers that expose those arguments. The clone-side abbreviation handling does not protect the push path. This issue is fixed in 4.0.0.
Affected configurations
• simple-git project simple-git (< 4.0.0)
Related
References
- https://github.com/steveukx/git-js/commit/98864c678444d9336357c844efa4fd5a7984c0d7 Patch
- https://github.com/steveukx/git-js/pull/1193 Patch
- https://github.com/steveukx/git-js/releases/tag/[email protected] Release Notes
- https://github.com/steveukx/git-js/security/advisories/GHSA-858h-whjf-mvg5 Exploit, Mitigation, Vendor Advisory