CVEvulnerability
CVE-2026-102828
9.2 CRITICAL
Official page ↗
- Status
- Analyzed
- Published
- 2026-09-29
- Last modified
- 2026-10-08
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 9.2 CRITICAL — CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-184, CWE-78
Description
simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. From 3.15.0 until 4.0.1, the default blockUnsafeOperationsPlugin does not classify trailer.<token>.cmd as unsafe configuration. An application that passes attacker-controlled values through SimpleGitOptions.config or inline -c arguments can therefore allow Git to invoke an attacker-selected shell command when git interpret-trailers processes the configured trailer. The command executes with the operating-system identity and permissions of the Node.js process. This issue is fixed in 4.0.1.
Affected configurations
• simple-git project simple-git (>= 3.15.0 < 4.0.1)
Related
References
- https://github.com/steveukx/git-js/commit/d762810c13b331ff1e5eb24c0b434646d2a8d1b3 Patch
- https://github.com/steveukx/git-js/pull/1198 Patch
- https://github.com/steveukx/git-js/releases/tag/[email protected] Release Notes
- https://github.com/steveukx/git-js/security/advisories/GHSA-x6jw-m9v5-85vh Mitigation, Vendor Advisory