CVEvulnerability
CVE-2026-103552
7.3 HIGH
Official page ↗
- Status
- Deferred
- Published
- 2026-10-02
- Last modified
- 2026-10-02
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 7.3 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- Weaknesses
- CWE-121
Description
Stack Overflow vulnerability in Apache Directory LDAP API.
Before binding, a client can send a deeply nested search filter that overflows the stack in the server's decoder.
This issue affects Apache Directory LDAP API: from 1.2.0 before 1.2.9.
Users are recommended to upgrade to version 1.2.9, which fixes the issue.
Related
Weakness · CWE (1)
- CWE-121 Stack-based Buffer Overflow weakness
References
- https://lists.apache.org/thread.html/fn3bwknn57266hx66w9vv6b4k8rfwcx7 lists.apache.org
- http://www.openwall.com/lists/oss-security/2026/10/02/4 www.openwall.com