CVEvulnerability

CVE-2026-104711

9.8 CRITICAL Published 2026-10-05 Modified 2026-10-08 Official page ↗
Status
Analyzed
Published
2026-10-05
Last modified
2026-10-08
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-917

Description

Improper neutralization of special elements used in an expression language statement ('Expression Language Injection') vulnerability in Apache Struts. If the application is configured to use the legacy RESTful action mapper, a crafted request can inject an OGNL expression that may lead to remote code execution. Struts 7 is affected only when the OGNL allowlist is disabled; it is enabled by default. Applications using the default action mapper, the restful2 mapper, or the Struts REST plugin are not affected. This issue affects Apache Struts: from 2.0.0 through 2.3.37, from 2.5.0 through 2.5.33, from 6.0.0 through 6.11.0, from 7.0.0 through 7.3.0. Users are recommended to upgrade to version 6.12.0 or 7.4.0, which fixes the issue.

Affected configurations

• apache struts (>= 2.0.0 <= 2.3.37) • apache struts (>= 2.5.0 <= 2.5.33) • apache struts (>= 6.0.0 < 6.12.0) • apache struts (>= 7.0.0 < 7.4.0)

Related

Weakness · CWE (1)

  • CWE-917 Improper Neutralization of Special Elements used in an Expression Language Statement weakness

References