CVEvulnerability
CVE-2026-106100
7.1 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-10-06
- Last modified
- 2026-10-15
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.1 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N
- Weaknesses
- CWE-639, CWE-915
Description
Payload is a free and open source headless content management system. In @payloadcms/db-mongodb versions before 3.87.0 and canary versions before 4.0.0-canary.20, an authenticated user who can update a document can modify fields that field-level write access control does not permit that user to change. The Postgres and SQLite adapters are not affected. This issue is fixed in versions 3.87.0 and 4.0.0-canary.20.
Affected configurations
• payloadcms payload (< 3.87.0)
• payloadcms payload 4.0.0
Related
References
- https://github.com/payloadcms/payload/commit/2a69863deb0e3c87e36c1b3b17ab2d5b02fcb941 Patch
- https://github.com/payloadcms/payload/commit/8f77dffa9552885ec2710768cfee15b57e389935 Patch
- https://github.com/payloadcms/payload/releases/tag/v3.87.0 Release Notes
- https://github.com/payloadcms/payload/security/advisories/GHSA-4ww4-68q3-h7g5 Vendor Advisory