CVEvulnerability
CVE-2026-106456
6.5 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2026-10-06
- Last modified
- 2026-10-27
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 4.8 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-863
Description
Backstage is an open framework for building developer portals. From 0.5.0 until 0.6.18, the @backstage/plugin-proxy-backend package is affected by inconsistent credential enforcement for overlapping proxy routes. An operator can configure overlapping proxy paths with different credential requirements. When a parent path permits unauthenticated access and a nested path requires credentials, the parent exemption can also cover requests handled by the nested proxy. An unauthenticated caller may therefore reach the nested upstream through Backstage, including with static upstream credentials configured for that proxy. This issue is fixed in version 0.6.18.
Affected configurations
• linuxfoundation backstage\/plugin-proxy-backend (>= 0.5.0 < 0.6.18)
• linuxfoundation backstage (>= 1.28.0 < 1.55.0)
Related
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness