CVEvulnerability
CVE-2026-106580
8.2 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-10-07
- Last modified
- 2026-10-21
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 4.0 MEDIUM — CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:L
- CVSS 3.1 ([email protected])
- 8.2 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H
- Weaknesses
- CWE-284, CWE-400
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to 7.1.2-31 and 6.9.13-56, a missing security-policy check in the CUT encoder allows a crafted local encoding operation to read data that policy should deny and can also cause a crash. This issue is fixed in versions 7.1.2-31 and 6.9.13-56.
Affected configurations
• imagemagick imagemagick (< 6.9.13-56)
• imagemagick imagemagick (>= 7.0.0-0 < 7.1.2-31)
Related
References
- https://github.com/ImageMagick/ImageMagick/commit/768bdd0dbb9a9ad743b6a6e557126b788b325970 Patch
- https://github.com/ImageMagick/ImageMagick/releases/tag/7.1.2-31 Patch, Release Notes
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-r868-pmwh-fv2c Vendor Advisory
- https://github.com/ImageMagick/ImageMagick6/commit/ad178e41fce2afa6be2b91fb4e7f41c4c5448117 Patch
- https://github.com/ImageMagick/ImageMagick6/releases/tag/6.9.13-56 Patch, Release Notes