CVEvulnerability
CVE-2026-107812
7.5 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-10-09
- Last modified
- 2026-10-20
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-494
Description
Nginx UI is a web user interface for the Nginx web server. From 2.0.0 until 2.5.0, the self-upgrade mechanism validates a downloaded binary only with a same-origin digest obtained from the same upgrade mirror. A compromised mirror or network attacker able to alter both responses can supply a malicious executable and matching digest. An operator-triggered upgrade is required, and the application installs and runs the attacker-controlled code in the Nginx UI process context on the next upgrade. This issue is fixed in version 2.5.0.
Affected configurations
• nginxui nginx ui (>= 2.0.0 < 2.5.0)
Related
Weakness · CWE (1)
- CWE-494 Download of Code Without Integrity Check weakness
References
- https://github.com/0xJacky/nginx-ui/commit/580585516dd87a8b176bcdac258db70c3b64b7ec Patch
- https://github.com/0xJacky/nginx-ui/releases/tag/v2.5.0 Release Notes
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-662p-52hx-cmh2 Exploit, Vendor Advisory
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-662p-52hx-cmh2 Exploit, Vendor Advisory