CVEvulnerability
CVE-2026-108836
5.5 MEDIUM
Official page ↗
- Status
- Deferred
- Published
- 2026-10-12
- Last modified
- 2026-10-13
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 5.5 MEDIUM — CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 7.3 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- CVSS 2.0 ([email protected])
- 7.5 HIGH — AV:N/AC:L/Au:N/C:P/I:P/A:P
- Weaknesses
- CWE-918
Description
A vulnerability has been found in Ollama up to 0.34.1. The affected element is the function IsValid of the file types/model/name.go of the component Pull API. The manipulation leads to server-side request forgery. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.34.2 is sufficient to fix this issue. The identifier of the patch is dfabde4539e42ba1e1eab50a3a50b88aea7958a0. It is suggested to upgrade the affected component.
Related
Weakness · CWE (1)
- CWE-918 Server-Side Request Forgery weakness
References
- https://github.com/aLtEr6/test.git github.com
- https://github.com/aLtEr6/test/blob/main/test.pdf github.com
- https://github.com/ollama/ollama/ github.com
- https://github.com/ollama/ollama/commit/dfabde4539e42ba1e1eab50a3a50b88aea7958a0 github.com
- https://github.com/ollama/ollama/pull/18512 github.com
- https://github.com/ollama/ollama/releases/tag/v0.34.2 github.com
- https://vuldb.com/cve/CVE-2026-108836 vuldb.com
- https://vuldb.com/submit/972855 vuldb.com
- https://vuldb.com/vuln/416610 vuldb.com
- https://vuldb.com/vuln/416610/cti vuldb.com